MultiCS & CSP & OScam Exchange Forum

This is a sample guest message. Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

CSP and Nginx



Ammar Gaffar

New Member
Member
Joined
Dec 31, 2014
Messages
13
Reaction score
4
Points
3
Location
Khartoum
Unfortunately, this configuration will work well only for HTTP protocol, not TCP protocol.

I tried even with HAProxy before but no luck so far!
 

Newtman

New Member
Member
Joined
Nov 7, 2014
Messages
14
Reaction score
0
Points
1
Unfortunately, this configuration will work well only for HTTP protocol, not TCP protocol.

I tried even with HAProxy before but no luck so far!
Hi,

Nginx work for me, I see the connections and work OK. But the origin IP in CSP is the RP and not the client.
 

Ammar Gaffar

New Member
Member
Joined
Dec 31, 2014
Messages
13
Reaction score
4
Points
3
Location
Khartoum
This is what I am talking about, the client IP address is not forwarding for TCP connections, both Nginx and HAProxy are working just fine as a load balancers but none of them are forwarding the original client IP address, in all of your application servers you will see all users are connected from one IP address which is your Nginx server!
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.



Top
AdBlock Detected

We get it, advertisements are annoying!

Sure, ad-blocking software does a great job at blocking ads, but it also blocks useful features of our website. For the best site experience please disable your AdBlocker.

I've Disabled AdBlock